Wednesday, November 18, 2009

Dublin has been renamed Windows AppFabric

Dublin and Velocity have been renamed to Windows AppFabric and the Beta 1 version is available at http://msdn.microsoft.com/en-us/windowsserver/ee695849.aspx. The link also includes documentation, samples and virtual labs. I would have preferred the name Application Fabric, but for some reason that suggestion was not followed.

Here is a summary of Windows AppFabric (from Brian Loesgen’s blog http://www.brianloesgen.com/blog/2009/11/17/goodbye-dublin-hello-windows-appfabric.html ):

Windows Server AppFabric is a new set of capabilities, bringing together the functionality of Dublin, as well as Velocity (a high-performance, distributed, highly-scalable in-memory cache). In a related move, the Service Bus and Access Control Services that were formerly part of the .NET Services brand have also been rebranded and we now have we now have “Windows Azure platform AppFabric Service Bus” and “Windows Azure platform AppFabric Access Control services”

Thursday, November 12, 2009

Active Directory Error - Why Developer's shouldn't setup the AD

I am doing a POC for a client and in doing so I had to setup two servers on a hosted environment. First, let me say that I am not a AD person and should probably never be allowed to touch the AD settings, but since this is a POC I am playing the role of Architect, Developer, and Infrastructure Support.


I started by using the Server Roles to setup the AD on the first server. The server is a Windows Server 2008 box (not R2). I went through the wizard, everything worked and on the reboot I was able to login to the machine (whew).


After adding the required BizTalk groups and users, I went to add the second computer to the domain. I kept getting the error below. I tried to add the computer through the AD Users and Computers screen, and it still did not work. The fix was very easy, but it took me some time - probably because I am developer and did not understand the network lingo. So here is the error and the fix:


Error:


The following error occurred when DNS was queried for the service location (SRV) resource record used to locate a domain controller for domain :

The error was: "DNS name does not exist."

(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.....

Common causes of this error include the following:

- The DNS SRV records required to locate a domain controller for the domain are not registered in DNS. These records are registered with a DNS server automatically when a domain controller is added to a domain. They are updated by the domain controller at set intervals. This computer is configured to use DNS servers with following IP addresses:


- One or more of the following zones do not include delegation to its child zone:


FIX:


1) On the server you are trying to add to the domain, Open the Network and Sharing Center.

2) Select Manager you connections.

3) On the correct connection (more than likely the LAN connection) right click and select properties.

4) Select the TCP/IPv4 option and select properties.

5) Select the Advanced button and then select the DNS tab.

6) Add the IP address of the DNS server and move it to the top of the list.

7) Select Ok, Ok, Ok.

8) Go to Computer Settings and change the domain.

9) Restart the computer and everything should now work :).


Monday, November 02, 2009

UDDI ArgumentNullException: Value cannot be null

Below is a link that I have used a couple of time now:

UDDI ArgumentNullException: Value cannot be null

I too forget to add the transport type category in UDDI. I remember the instances, but forget about categories. Would be nice to have an UDDI-ESB configuration tool. I'll create one in my spare time...